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OutSystems

Personal Environment: サービスを利用できない - HTTPエラー503

症状

症状1: HTTPエラー503: サービスを利用できない

eSpaceユーザー(またはPersonal Environmentで作成した他のeSpace)にアクセスしようとすると、エラーメッセージが表示されます。

ページのタイトルに「Service Unavailable」と表示されます。ページの内容は以下のとおりです。

症状2: Service Studioから1-Click Publishを実行するとエラーが発生する

Service Studioを使用してeSpaceをパブリッシュしています。デプロイフェーズ(3)は異常に時間がかかり、デプロイが失敗したというエラーで終了します。エラーの詳細にマウスポインタを重ねると、以下のように「(503) Server Unavailable」と表示されます。

このメッセージが表示された後、症状1に適用される内容を確認します。

症状3: Service Centerのエラー: サービス「Deployment」にアクセスできなかった

Service Centerにアクセスしようとすると、以下のようにDeployment Serviceの停止に関連するエラーメッセージがEnvironment Healthに表示されます。

このメッセージが表示された後、症状1に適用される内容を確認します。

症状4: LifeTimeのエラー: Environment Healthの問題: Deployment Serviceがダウンしている

LifeTimeにアクセスしようとすると、Environment Healthに関連するエラーが表示されます。詳細をクリックすると、Deployment Serviceに関連するエラーが表示されます。

このメッセージが表示された後、症状1に適用される内容を確認します。

原因

上記の症状が発生している場合、Personal Environmentは自動的に無効になっています。この問題が発生した原因は、いずれかのアプリケーションがリソースの容使用量を超えたためです。

この保護メカニズムによって、以下のいずれかが発生した場合にPersonal Environmentが無効になります。

1.ある時点でアプリケーションがPersonal Environmentのメモリの許容限度に達した

2.長時間にわたって過剰にCPUを使用するアプリケーションを作成した。

3.環境で繰り返しクラッシュを引き起こすパターン(統合時の無限ループや誤ったコードパターン)を作成した。

4.複雑なアプリケーションを過剰に多く実行した。

解決策

Personal Environmentを復旧するには、以下の2つの方法があります。

  • 症状12の場合は、Service Studioで以下のエラーが表示されます。

Free up the resources]をクリックすると、以下のページにリダイレクトされます。このページで、[Free Up Resources]クリック**する必要があります。

同じ条件に該当する場合、Personal Environmentのリソースを解放しても、自動的に再びリソースの上限に達しないようにすることはありません。そのため、作業していたアプリケーションのうち、環境の一時的な停止をトリガーした可能性のあるアプリケーションを必ずトラブルシューティングしてください。

  • 症状34の場合、またはリソースを解放してアプリをトラブルシューティングしても問題が解決しない場合は、サポートにお問い合わせください。Personal Environmentの復旧に加えて、この障害の原因となった問題の解決を支援します。

プロパティ

Personal Environmentのすべてのバージョンに適用されます。