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OutSystems

管理コンソールアクセスエラー: 「You are not authorized to view this page」

症状

Service CenterやLifetimeへのアクセスを必要とする日常的なタスクを実行する際に、ブラウザを開いて管理コンソールへの正しいパスを入力したとします。しかし、通常のログイン画面が表示されずに、以下のメッセージが掲載されたエラー画面が表示されます。

「You are not authorized to view this page」

原因

これは通常、内部ネットワーク構成に含まれないネットワークからアクセスしようとしているため、期待どおりにマシンからService CenterやLifeTimeにアクセスできないということを意味します。

解決策

OutSystems 9.1 Bali以前

サーバーへのローカルアクセスは可能ですが、内部ネットワークのアドレスに「127.0.0.1」などが含まれていないため、サーバーのマシンからService CenterやLifeTimeにアクセスすることはできません。動作の詳細な説明については、Configuration Toolのドキュメントをご覧ください。

この問題を解決するには、サーバーにアクセスして以下の手順を実行します。

  • スタンドアロンマシンまたはいずれかのファーム環境でConfiguration Toolを開きます。

  • [Network]タブで、内部ネットワークに正しい情報を設定します(詳細については、オンラインヘルプ for more details)をご覧ください)。

  • 変更を適用してConfiguration Toolを終了します。

    • プロンプトが表示されたら、OutSystemsサービスを再起動します

    • Service Centerをインストールする必要はありません。

  • 環境のすべてのマシンで、IISを再起動する必要があります。

OutSystems 10以降

内部ネットワークはService Centerで構成されています。環境にローカルアクセスできるユーザーは、内部ネットワークに「127.0.0.1」アドレスが設定されていない場合でも、常に管理コンソールにアクセスできる必要があります。そうすることで、ユーザーが随時各マシンのService Centerにアクセスして内部ネットワーク構成を調整できるようになります。これを実現するには、サーバー(またはファーム環境のいずれかのマシン)にアクセスして以下の手順を実行します。

  • Service Centerの適切な[Network Security]([Administration > Security > Network Security])画面にアクセスし、内部ネットワークを構成します。

  • [Trusted proxy addresses]フィールドがインフラに対して正しく構成されていることを確認してください。この構成が問題の根本的な原因である可能性があるためです。

  • 変更を適用します。

正しいアドレスが追加されていれば、これで管理コンソールに再びアクセスできるはずです。