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OutSystems

ファイアウォールが原因でデバッガが動作しない

症状

  • デバッグセッションを開始しましたが、デバッガがブレークポイントに到達しません。
  • デバッグセッションの途中でデバッガがハングアップします。
  • デバッグセッションの途中でデバッガの動作が停止します。

原因

デバッグセッション中、IDEはHTTPSまたはHTTP(HTTPSが使用できない場合)を使用してアプリがデプロイされている環境と通信します。

一般的なデバッグセッションでは、IDEが環境との通信を複数回繰り返します。そのため、IDEはデバッガの処理を高速に保つために、環境に対してオープンな接続を維持するように求めます。

導入されているアンチウイルスソフト、ファイアウォール、その他のネットワーク要素によっては、少し後でIDEと環境の間の接続がこれらの要素によって突然切断される可能性があります。

このとき、デバッガがハングアップします。

解決策

IDEを構成し、環境へのリクエストを行うたびに新しい接続を確立するようにします。

Edit]メニューで、[Preferences]にある[Use One Connection per Request in Debugger]オプションにチェックを付けます。

この解決策では、OutSystemsプラットフォームがバージョン9.0.1.15、8.0.1.43以上である必要があります。

このオプションを有効にすると、デバッガが遅くなったように感じる場合があります。

関連リソース

デバッグセッションに影響を及ぼすその他の問題がある場合があります。デバッガの誤動作のその他の原因をご覧ください。