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「Could not establish trust relationship for the SSL/TLS」エラー

 

OutSystems

「Could not establish trust relationship for the SSL/TLS」エラー

症状

Webサービスの呼び出し時または公開時に、以下のいずれかのエラーが発生します。

  • The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel
  • PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

原因

考えられる問題は、以下のとおりです。

  • 無効な証明書を使用している。
  • 証明書が信頼できる認証局によって発行されていない。

これは、非本番環境での連携のときにある程度の頻度で発生します。その理由は、通常これらの環境にインストールされている証明書が自己署名証明書であるためです。

解決策

ブラウザでサービスURLにアクセスし、証明書エラーを確認します。ブラウザに表示されるエラーメッセージは、エラーの原因をトラブルシューティングする際に役立ちます。ローカルブラウザに証明書エラーが表示されない場合は、問題が発生しているサーバーにインストールされたブラウザでテストを繰り返します。

SSL証明書の検証に失敗する最もよくある原因は、以下のとおりです。

  • URLで使用されているホスト名が証明書のホスト名と一致していません。使用しているURLと証明書の「Issued to」フィールドのURLが同じであることを確認してください。
  • 証明書の期限が切れています。有効な証明書をインストールするか、連携しようとしているシステムのサポートに問い合わせてください。
  • 証明書を発行した証明書ルート認証局がサーバーで信頼されていません。サーバーにルート証明書をインストールしたことを確認してください。
  • 証明書が自己署名証明書です。信頼できる証明書をインストールしたことを確認してください。