Skip to main content
OutSystems

Debugger not working because of a firewall

Symptom

  • I start a debug session, but the debugger never reaches a breakpoint;
  • I'm in the middle of a debug session, and the debugger just hangs;
  • I'm in the middle of a debug session, and the debugger stops working.

Cause

During a debug session, the IDE contacts the environment where your app is deployed using HTTPS or HTTP if the first option is not available.

During a typical debug session the IDE communicates back and forward several times with the environment. So to keep the debugger fast, the IDE asks the environment to keep an open connection.

Depending on your anti-virus, firewalls, or other network elements you might have in place, it's possible that these elements abruptly close the connection between the IDE and the environment after a while.

And that's when the debugger hangs.

Solution

Configure the IDE so that it establishes a new connection for each request made to the environment.

In Edit menu, under Preferences, check the Use One Connection per Request in Debugger option.

This solution requires OutSystems platform versions 9.0.1.15, 8.0.1.43, or above.

By activating this option, it's possible that the debugger will feel slower.

More information

There might be other problems affecting your debug session. Check other reasons for the debugger to misbehave.